Globe/TM Load Maintenance
Incident Report for Coins.ph
Resolved
This incident has been resolved.
Posted 7 days ago. May 17, 2018 - 01:29 GMT+08:00
Investigating
Please be advised that our provider will be undergoing system maintenance on May 17, 2018, 11:30PM to 2:00AM. During this time, Globe/TM load will be unavailable.
Posted 7 days ago. May 16, 2018 - 23:17 GMT+08:00