[Coins.ph] Cash in Delays
Incident Report for Coins.ph
Resolved
This incident has been resolved.
Posted about 1 month ago. Mar 18, 2018 - 10:56 GMT+08:00
Investigating
We are currently experiencing delays in processing cash ins. We sincerely apologize for the inconvenience. Our technical team is already working on resolving this issue at the soonest possible time.
Posted about 1 month ago. Mar 17, 2018 - 22:29 GMT+08:00