[Coins.ph] Possible Transaction Delays
Incident Report for Coins.ph
Resolved
This incident has been resolved.
Posted Mar 09, 2018 - 00:21 GMT+08:00
Investigating
Please be advised that some Coins.ph wallet transfers, cash outs, bills and load transactions may be delayed. Our technical team working to resolve this issue as soon as possible. We sincerely apologize for the inconvenience.
Posted Mar 08, 2018 - 22:13 GMT+08:00