Temporary Service Downtime
Incident Report for Coins.ph
Resolved
This incident has been resolved.
Posted 22 days ago. May 02, 2018 - 18:02 GMT+08:00
Identified
Please be advised that we are currently experiencing delays with processing transactions. Affected services include cash ins, cash outs, bill payments, wallet to wallet, and load transactions. We apologize for any inconvenience this may have caused and are working on having it back up as soon as possible.
Posted 22 days ago. May 02, 2018 - 12:16 GMT+08:00