[Service Provider] Maintenance
Incident Report for Coins.ph
Resolved
This incident has been resolved.
Posted 2 months ago. Mar 11, 2018 - 08:46 GMT+08:00
Identified
Please be advised that GCash is undergoing system maintenance. During this time, Globe/TM buy load and GCash cash out services will be unavailable. We will provide an update once our service provider is back to normal operations.
Posted 2 months ago. Mar 10, 2018 - 23:00 GMT+08:00