[Globe/TM] Load Transactions
Incident Report for Coins.ph
Resolved
This incident has been resolved.
Posted 12 months ago. Jun 14, 2018 - 20:16 GMT+08:00
Identified
Please be advised that Globe/TM Load is temporarily unavailable. We apologize for any inconvenience this may have caused. We are coordinating with the provider in order to restore functionality at the soonest possible time.
Posted 12 months ago. Jun 14, 2018 - 19:49 GMT+08:00