[GCash] Cash Out Maintenance
Incident Report for Coins.ph
Resolved
This incident has been resolved.
Posted about 1 year ago. Jun 05, 2018 - 08:15 GMT+08:00
Identified
Please be advised that GCash is undergoing system maintenance from June 5, 2018, 11PM to June 5, 2018, 8AM. During this time, cash out to GCash will be unavailable.
Posted about 1 year ago. Jun 04, 2018 - 23:20 GMT+08:00