Smart Load Buy Load
Incident Report for Coins.ph
Resolved
This incident has been resolved.
Posted 3 months ago. May 27, 2018 - 15:46 GMT+08:00
Investigating
Please be advised that Smart load option is temporarily unavailable due to the network's downtime. We apologize for any inconvenience this may have caused and are working on having it back up as soon as possible.
Posted 3 months ago. May 27, 2018 - 13:44 GMT+08:00