Globe Load and GCash Cash Out
Incident Report for Coins.ph
Resolved
This incident has been resolved.
Posted 4 months ago. Feb 13, 2018 - 19:12 GMT+08:00
Identified
Please be advised that Globe and TM load services and GCash cash outs are temporarily unavailable. We are coordinating with our provider to have it available at the soonest possible time. Apologies for the inconvenience.
Posted 4 months ago. Feb 10, 2018 - 21:06 GMT+08:00