Security Bank eGiveCash Downtime
Incident Report for Coins.ph
Resolved
This incident has been resolved.
Posted 4 months ago. Feb 21, 2018 - 10:47 GMT+08:00
Investigating
Please be advised that the Security Bank eGiveCash Cash out option is temporarily unavailable. The bank is currently unable to create new transactions at the moment. We apologize for any inconvenience this may have caused and are working with the bank on having it back up as soon as possible.
Posted 4 months ago. Feb 21, 2018 - 09:53 GMT+08:00