Globe/TM Buy Load
Incident Report for Coins.ph
Resolved
This incident has been resolved.
Posted 4 months ago. Aug 07, 2018 - 16:37 GMT+08:00
Investigating
Please be advised that Globe/TM buy load option is temporarily unavailable. We apologize for any inconvenience this may have caused. We are coordinating with the provider in order to restore functionality at the soonest possible time.
Posted 4 months ago. Aug 07, 2018 - 14:11 GMT+08:00
This incident affected: Buy Load (Globe / TM).