[GCash] Maintenance
Incident Report for Coins.ph
Resolved
This incident has been resolved.
Posted about 1 month ago. Jul 20, 2018 - 05:20 GMT+08:00
Identified
Please be advised that our provuder is undergoing system maintenance. During this time, Globe/TM load and GCash Cash Out will be unavailable.
Posted about 1 month ago. Jul 19, 2018 - 23:39 GMT+08:00