Coins.ph Email Notifications
Incident Report for Coins.ph
Resolved
This incident has been resolved.
Posted 5 months ago. Jan 31, 2018 - 11:37 GMT+08:00
Investigating
Please be advised that there is a delay in receiving email notifications regarding your transactions. We are currently coordinating with our service provider to have it resolved as soon as possible.
Posted 5 months ago. Jan 30, 2018 - 15:39 GMT+08:00