[Bayad Center] Bills Payment
Incident Report for Coins.ph
Resolved
This incident has been resolved.
Posted about 1 year ago. May 29, 2018 - 12:40 GMT+08:00
Identified
Please be advised that we're currently experiencing some delays in processing bills through Bayad Center. We're working with our provider to restore full functionality. We're very sorry for the inconvenience.
Posted about 1 year ago. May 29, 2018 - 11:12 GMT+08:00