Coins.ph website
Incident Report for Coins.ph
Resolved
This incident has been resolved.
Posted 4 months ago. Apr 30, 2018 - 18:35 GMT+08:00
Investigating
We are currently experiencing delays in processing wallet transfers, cash outs, bill payments, and load transactions. We sincerely apologize for the inconvenience. Our technical team is already working on resolving this issue at the soonest possible time.
Posted 4 months ago. Apr 30, 2018 - 17:43 GMT+08:00