[Cash Out] Security bank eGiveCash
Incident Report for Coins.ph
Resolved
This incident has been resolved.
Posted 5 months ago. Jul 26, 2018 - 17:45 GMT+08:00
Update
We are continuing to investigate this issue.
Posted 5 months ago. Jul 26, 2018 - 17:45 GMT+08:00
Investigating
Please be advised that eGive Cash cash out option is temporarily unavailable. We apologize for any inconvenience this may have caused. We are coordinating with the bank in order to restore functionality at the soonest possible time.
Posted 5 months ago. Jul 26, 2018 - 17:10 GMT+08:00