Unionbank Cash in
Incident Report for Coins.ph
Resolved
This incident has been resolved.
Posted 6 months ago. Jan 02, 2018 - 18:09 GMT+08:00
Investigating
Please be advised that Unionbank Online and Cash Deposit Cash in options are temporarily unavailable. The bank is encountering an issue with updating our account statement required in processing cash ins. We apologize for any inconvenience this may have caused and are working on having it back up as soon as possible.
Posted 6 months ago. Dec 31, 2017 - 13:13 GMT+08:00