GCash System Maintenance
Incident Report for Coins.ph
Resolved
This incident has been resolved.
Posted 5 months ago. Jan 17, 2018 - 11:59 GMT+08:00
Identified
Please be advised that GCash is undergoing system maintenance. During this time, GCash Cash Out option and Globe/TM prepaid load service will be unavailable.

We will be providing an update as soon as our service is back to normal operations.
Posted 5 months ago. Jan 16, 2018 - 22:22 GMT+08:00