[Globe/TM] Load Transactions
Incident Report for Coins.ph
Resolved
This incident has been resolved.
Posted 19 days ago. Jun 30, 2018 - 22:04 GMT+08:00
Investigating
Please be advised that Globe/TM Load option is temporarily unavailable. We apologize for any inconvenience this may have caused. We are coordinating with the provider in order to restore functionality at the soonest possible time.
Posted 19 days ago. Jun 30, 2018 - 20:55 GMT+08:00
This incident affected: Buy Load (Globe / TM).