Bank of Commerce System Maintenance
Incident Report for Coins.ph
Resolved
This incident has been resolved.
Posted 5 months ago. Jul 07, 2018 - 15:01 GMT+08:00
Identified
Please be advised that Bank of Commerce is undergoing system maintenance. During this time, Bank of Commerce Online Cash in option will be unavailable.
Posted 5 months ago. Jul 07, 2018 - 12:52 GMT+08:00