Globe GCash Maintenance
Incident Report for Coins.ph
Resolved
This incident has been resolved.
Posted 5 months ago. Jan 07, 2018 - 11:10 GMT+08:00
Investigating
Please be advised that Globe GCash is undergoing system maintenance. During this time, Globe GCash cash out and Globe/TM buy load options will be unavailable.
Posted 5 months ago. Jan 06, 2018 - 23:47 GMT+08:00