Security Bank eGiveCash Downtime
Incident Report for Coins.ph
Resolved
This incident has been resolved.
Posted 5 months ago. Jan 20, 2018 - 10:28 GMT+08:00
Investigating
Please be advised that the Security Bank eGiveCash cash out option is temporarily unavailable. We apologize for any inconvenience this may have caused and are working on having it back up as soon as possible.
Posted 5 months ago. Jan 20, 2018 - 07:37 GMT+08:00