BPI (via Dragonpay) Cash in
Incident Report for Coins.ph
Resolved
This incident has been resolved.
Posted 10 months ago. Jul 06, 2018 - 09:41 GMT+08:00
Monitoring
Please be advised that BPI (via Dragonpay) Cash in option is temporarily unavailable. We apologize for any inconvenience this may have caused and are working on having it back up as soon as possible.
Posted 10 months ago. Jul 05, 2018 - 10:10 GMT+08:00