7-Eleven Seven Connect and CLIQQ Cash in
Incident Report for Coins.ph
Resolved
This incident has been resolved.
Posted 4 months ago. Jul 10, 2018 - 14:29 GMT+08:00
Investigating
Please be advised that 7-Eleven via Seven Connect and CLIQQ Cash in option is temporarily unavailable. We apologize for any inconvenience this may have caused and are working on having it back up as soon as possible.
Posted 4 months ago. Jul 10, 2018 - 08:24 GMT+08:00