Globe/TM Load Maintenance
Incident Report for Coins.ph
Resolved
This incident has been resolved.
Posted 24 days ago. Oct 27, 2018 - 11:59 GMT+08:00
Investigating
Please be advised that we will be having a system maintenance for Globe/TM load service at October 26, 2018, 11PM. During this time, Globe/TM load will be unavailable.
Posted 25 days ago. Oct 26, 2018 - 18:32 GMT+08:00