Globe Buy Load
Incident Report for Coins.ph
Resolved
This incident has been resolved.
Posted 5 months ago. Jan 15, 2018 - 14:02 GMT+08:00
Identified
Please be advised that Globe prepaid load option is temporarily unavailable. We apologize for any inconvenience this may have caused. Our team is working on having it back up as soon as possible.
Posted 5 months ago. Jan 13, 2018 - 23:18 GMT+08:00