[Globe/TM] Load Transactions
Incident Report for Coins.ph
Resolved
This incident has been resolved.
Posted 4 months ago. Jun 11, 2018 - 22:44 GMT+08:00
Investigating
Please be advised that Globe/TM Load is temporarily unavailable. We apologize for any inconvenience this may have caused. We are coordinating with the bank in order to restore functionality at the soonest possible time.
Posted 4 months ago. Jun 11, 2018 - 19:58 GMT+08:00