Processing delays due to inclement weather conditions.
Incident Report for Coins.ph
Resolved
This incident has been resolved.
Posted Nov 16, 2020 - 09:48 GMT+08:00
Update
We are continuing to monitor for any further issues.
Posted Nov 12, 2020 - 14:06 GMT+08:00
Monitoring
Due to inclement weather conditions, non-InstaPay bank cash-outs made will be processed on the following banking day, November 13, 2020.

Remittance Center cash in and cash outs in the NCR and Luzon areas may also be affected.
Posted Nov 12, 2020 - 13:05 GMT+08:00
This incident affected: Cash In (Cebuana Lhuillier Instant Cash In, Palawan Pawnshop Cash In, PESONet Cash In) and Cash Out (Palawan Express Pera Padala, M Lhuillier Kwarta Padala, LBC Instant Cash Out, PESONet Cashout).