Bayad Center System Maintenance
Incident Report for Coins.ph
Resolved
This incident has been resolved.
Posted 8 months ago. Apr 24, 2018 - 07:48 GMT+08:00
Update
Bayad Center is currently undergoing system maintenance. During this time, some of our bill options will be unavailable. We will provide an update once our service provider is back to normal operations.
Posted 8 months ago. Apr 23, 2018 - 22:04 GMT+08:00
Identified
Bayad Center will be undergoing system maintenance tonight, April 23, 2018 at 10:00 PM (PH time). During this time, some of our bill options will be unavailable. We will provide an update once our service provider is back to normal operations.
Posted 8 months ago. Apr 23, 2018 - 13:12 GMT+08:00