Globe/TM and GCash Cash Out Transactions
Incident Report for Coins.ph
Resolved
This incident has been resolved.
Posted 14 days ago. Jul 05, 2018 - 21:40 GMT+08:00
Identified
Please be advised that Globe/TM load and GCash Cash out are temporarily unavailable. We apologize for any inconvenience this may have caused. We are coordinating with the provider in order to restore functionality at the soonest possible time.
Posted 14 days ago. Jul 05, 2018 - 19:12 GMT+08:00
This incident affected: Buy Load (Globe / TM).