[Globe/TM] Load Transactions
Incident Report for Coins.ph
Resolved
This incident has been resolved.
Posted 12 months ago. Jul 01, 2018 - 21:57 GMT+08:00
Investigating
Please be advised that Globe/TM Load option is temporarily unavailable. We apologize for any inconvenience this may have caused. We are coordinating with the bank in order to restore functionality at the soonest possible time.
Posted 12 months ago. Jul 01, 2018 - 19:28 GMT+08:00
This incident affected: Buy Load (Globe / TM).