GCash via Dragonpay Cash In
Incident Report for Coins.ph
Resolved
This incident has been resolved.
Posted 3 months ago. Jun 25, 2018 - 14:39 GMT+08:00
Investigating
Please be advised that GCash (via Dragonpay) Cash in option is temporarily unavailable. We apologize for any inconvenience this may have caused and are working on having it back up as soon as possible.
Posted 6 months ago. Apr 03, 2018 - 16:36 GMT+08:00