Smart Load Promos
Incident Report for Coins.ph
Resolved
This incident has been resolved.
Posted about 1 year ago. May 21, 2018 - 11:46 GMT+08:00
Investigating
Please be advised that we're currently experiencing some delays in processing Smart Load Promos transactions. We're working with our provider to restore full functionality. We're very sorry for the inconvenience.
Posted about 1 year ago. May 20, 2018 - 17:11 GMT+08:00