GCash Cash out Downtime
Incident Report for Coins.ph
Resolved
This incident has been resolved.
Posted 5 months ago. Jul 29, 2018 - 16:41 GMT+08:00
Investigating
We are currently investigating this issue.
Posted 5 months ago. Jul 29, 2018 - 10:58 GMT+08:00
Identified
Please be advised that GCash cash out option is temporarily unavailable. We apologize for any inconvenience this may have caused and are working on having it back up as soon as possible.
Posted 5 months ago. Jul 29, 2018 - 08:26 GMT+08:00
This incident affected: Buy Load (Globe / TM).