Temporary Service Interruption
Incident Report for Coins.ph
Resolved
This incident has been resolved.
Posted Aug 20, 2019 - 12:17 GMT+08:00
Investigating
Please be advised that we are currently experiencing delays with processing transactions. We apologize for any inconvenience this has caused and we are working on having it back up as soon as possible.
Posted Aug 20, 2019 - 11:19 GMT+08:00
This incident affected: Coins.ph Mobile App.