Security Bank eGiveCash Cash Out
Incident Report for Coins.ph
Resolved
This incident has been resolved.
Posted 3 months ago. May 28, 2018 - 17:28 GMT+08:00
Identified
Please be advised that eGive Cash cash out option is temporarily unavailable. We apologize for any inconvenience this may have caused. We are coordinating with the bank in order to restore functionality at the soonest possible time.
Posted 3 months ago. May 28, 2018 - 16:23 GMT+08:00