Issues Processing BTC Withdrawals
Incident Report for Coins.ph
Resolved
This incident has been resolved.
Posted May 19, 2023 - 18:03 GMT+08:00
Investigating
Please be advised that our BTC withdrawal services on Coins.ph are currently disabled. Rest assured that we are closely working with our technical team to resolve the issue as soon as possible.

In the meantime, you may withdraw your BTC through the Coins Pro website.
Posted May 16, 2023 - 18:40 GMT+08:00
This incident affected: Bitcoin Network Transfers (Withdrawals).