USDT Withdrawal is temporarily unavailable.
Incident Report for Coins.ph
Resolved
The incident has been resolved.
Posted May 16, 2022 - 21:08 GMT+08:00
Identified
The issue has been identified and our team is currently working on resolving this as soon as possible.
Posted May 16, 2022 - 12:25 GMT+08:00
This incident affected: External ERC-20 Transfers (Outgoing USDT).