Temporary Service Interruption
Incident Report for Coins.ph
Resolved
This incident has been resolved.
Posted 4 months ago. Mar 20, 2018 - 22:46 GMT+08:00
Identified
Please be advised that we are currently experiencing delays with processing transactions. Affected services include cash outs, bill payments, and load transactions. We apologize for any inconvenience this may have caused and are working on having it back up as soon as possible.
Posted 4 months ago. Mar 20, 2018 - 18:03 GMT+08:00