[Game Credits] Cherry Credits
Incident Report for Coins.ph
Resolved
This incident has been resolved.
Posted about 8 hours ago. Jul 19, 2018 - 01:46 GMT+08:00
Identified
Please be advised that Cherry Credits option is temporarily unavailable. We apologize for any inconvenience this may have caused. We are coordinating with the provider in order to restore functionality at the soonest possible time.
Posted 15 days ago. Jul 04, 2018 - 19:04 GMT+08:00