Globe/TM Load Promos
Incident Report for Coins.ph
Resolved
This incident has been resolved.
Posted about 1 year ago. Jul 11, 2018 - 10:46 GMT+08:00
Identified
Please be advised that Globe/TM Load Promos is temporarily unavailable. We apologize for any inconvenience this may have caused. We are coordinating with the provider in order to restore functionality at the soonest possible time.
Posted about 1 year ago. Jul 11, 2018 - 09:24 GMT+08:00