LOOKS and YGG Wallet (Temporary outage)
Incident Report for Coins.ph
Resolved
This incident has been resolved.
Posted Nov 13, 2022 - 23:12 GMT+08:00
Investigating
The following services are affected:
- Display of LOOKS and YGG wallet balances (Android), and
- YGG and LOOKS Conversions (iOS, Android, Web)

We are working with our technical team to bring back the full functionality of these services. Thank you!
Posted Nov 13, 2022 - 08:28 GMT+08:00
This incident affected: Digital Currency Conversion (YGG, LOOKS).