[Cash Out] Cebuana Lhuillier Express Padala
Incident Report for Coins.ph
Resolved
This incident has been resolved.
Posted 4 months ago. Mar 16, 2018 - 16:59 GMT+08:00
Identified
Please be advised that Cebuana Lhuillier Express Padala cash out option is temporarily unavailable. Our technical team working to resolve this issue as soon as possible. We sincerely apologize for the inconvenience.
Posted 4 months ago. Mar 16, 2018 - 13:26 GMT+08:00
Investigating
Please be advised that Cebuana Lhuillier Express Padala transactions may be delayed. Our technical team working to resolve this issue as soon as possible. We sincerely apologize for the inconvenience.
Posted 4 months ago. Mar 16, 2018 - 13:08 GMT+08:00