XRP Transaction Delays
Incident Report for Coins.ph
Resolved
This incident has been resolved.
Posted Dec 08, 2019 - 12:02 GMT+08:00
Investigating
There may be delays with your incoming and outgoing XRP transactions. Our team is investigating this issue further and we'll provide updates regarding this.
Posted Dec 08, 2019 - 10:51 GMT+08:00
This incident affected: External XRP Transfers (Incoming from External Wallets, Outgoing to External Wallets).