[Bills Payment] Bayad Center
Incident Report for Coins.ph
Resolved
This incident has been resolved.
Posted 5 months ago. Jan 13, 2018 - 13:40 GMT+08:00
Identified
Please be advised that Bayad Center is undergoing system maintenance. During this time, bill payments via Bayad Center will be unavailable.
Posted 5 months ago. Jan 12, 2018 - 22:26 GMT+08:00