PHPC Redemption

Incident Report for Coins.ph

Update

PHPC deposits and withdrawals are disabled.
Posted Jul 11, 2025 - 21:00 GMT+08:00

Update

Selling of PHPC is also also available through convert. Buying is still disabled.
Posted Jul 07, 2025 - 20:35 GMT+08:00

Update

PHPC deposits have been reenabled, while withdrawals and trading remain paused.
Posted Jul 07, 2025 - 13:50 GMT+08:00

Investigating

As PHPC transitions out of the regulatory sandbox, Coins.ph is redeeming all issued PHPC from the sandbox phase. To facilitate this process, PHPC deposits, withdrawals and trading will be paused starting July 4, 2:00 PM.

For more information, you may refer to this article: https://coins.ph/blog/convert-your-phpc-holdings-to-php-today/
Posted Jul 04, 2025 - 14:00 GMT+08:00