Coins.ph Buy Load and Cash In Services
Incident Report for Coins.ph
Resolved
This incident has been resolved.
Posted May 03, 2020 - 23:31 GMT+08:00
Investigating
We are currently experiencing a partial service downtime. Some buy load and cash in services may be temporarily unavailable. Our team is already fixing the issue. We are very sorry for the inconvenience.
Posted May 03, 2020 - 22:11 GMT+08:00