[Bayad Center] Maintenance
Incident Report for Coins.ph
Resolved
This incident has been resolved.
Posted 3 months ago. Jul 25, 2018 - 06:25 GMT+08:00
Identified
Please be advised that Bayad Center is undergoing system maintenance. During this time, bill payments processed Bayad Center will be unavailable.
Posted 3 months ago. Jul 24, 2018 - 21:44 GMT+08:00