Coins.ph Transactions
Incident Report for Coins.ph
Resolved
This incident has been resolved.
Posted 3 months ago. Sep 26, 2018 - 09:39 GMT+08:00
Investigating
We are currently experiencing delays in processing some cash ins, bill payments, and load transactions. We sincerely apologize for the inconvenience. Our technical team is already working on resolving this issue at the soonest possible time.
Posted 3 months ago. Sep 26, 2018 - 08:52 GMT+08:00