LOOKS (Temporary Outage)
Incident Report for Coins.ph
Resolved
This incident has been resolved.
Posted Mar 29, 2023 - 11:28 GMT+08:00
Investigating
The following services are affected:
- Display of LOOKS wallet balances, and
- LOOKS Conversions

We are working with our technical team to bring back the full functionality of these services. Thank you!
Posted Mar 28, 2023 - 07:00 GMT+08:00